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In simplest terms, selections allow you to single 
out or isolate pixels from the rest of a document, desig-
nating them for some Photoshop process to follow. You 
can edit, copy and paste, or move selected pixels while 
protecting the rest of the document from changes. As 
you select specifi c content in Photoshop, a marquee or 
fl ashing dashed border — often referred to as “march-
ing ants” — will designate the selection edges.

Photoshop allows many options for working with 
selections. You can select an entire layer or just specifi c 
content within a layer. You can save selections, and 
you can use selections between documents. Just as 
Photoshop allows you to add, subtract, and transform 
image information; you can add to, subtract from, and 
transform selections themselves.

You can make and modify selections in Photoshop 
with a variety of interchangeable tools and methods. 
This series looks at selection tools and the various 
ways you can select, move, and copy content in Pho-
toshop.
Selection Basics

Selections can be virtually any shape. They can 
have hard, crisp edges, or they can have soft, feath-
ered edges. You can select with a variety of tools, 
which can be used independently or in any number 
of combinations.

Primary selection tools. Located in the top-
most section of the Photoshop Toolbox; these include 
the Crop, Marquee, Lasso, and Magic Wand tools. You 
can use them in any combination and, alternately, 
create selections in any variety of shapes by adding 
to or subtracting from them as you work.

Refi ned selections. Using vector tools, such as 
the Pen tool or shape tools, you can convert vector 
paths into selections. You can also make selections 
based on color range. Photoshop offers several more 
sophisticated tools that allow you to extract objects or 
erase backgrounds, essentially combining the Select 
and Delete commands for you.

Masks and channels. You can make selections by 
painting onto masks or channels with any variety of Pho-
toshop brushes and then converting the masks or chan-
nels into selections. The Quick Mask option in the Toolbox 
provides a simple one-click method for converting between 
selection and mask. All selections saved in Photoshop are 
stored as alpha channels in the Channels palette.

Each selection tool and selection method offers you 
specifi c advantages to be considered or used in com-
bination with your own working style-and given image 
content. Consider just a few of the options available re-
garding selection strategies for content in this image, and 
apply them when considering your own selections:

A - Currently selected content is designated with a 
selection border. It can be actively edited, moved, copied, 
deleted, and so on.

B - The selection border defi nes the edges of 
selected area(s) and is designated by a marquee, or 
“marching ants.” (You can hide these for more accurate 
editing.)

C -Nonselected image areas are essentially 
protected from editing.

D - You can select sky with the Magic Wand; 
if you select with Color Range, you can pick up 
the sky between branches and leaves. In cases 
like this, in which you need to select the entire 
background, consider selecting the object rather 
than the background, duplicate the layer, and try 
the Extract fi lter on the object.

E - For objects, such as the truck that has 
smooth curves and sometimes little contrast 
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with the background, use the Pen tool and Bezier 
curves. You might look at contrast in individual 
channels; more contrast will better enable use 
of the Magnetic Lasso. Zoom in and add small 
selections together. You can also easily block in a 
solid large object like this by using a round brush, 
80%-90% hardness, in Quick Mask mode.

F - You can select high-contrast edges, such as 
the lower edge of the truck fender, with the Magnetic 
Lasso, or you can add/subtract with the Magic Wand 
at low tolerance settings.

After you make a selection, you have several 
basic options:

Save the selection. As in the example, some 
selections may take time and patience to create; it 
is always wise to save the selection-even as you go. 
Save versions of the selection with hard edges before 
feathering.

Feather selection edges. To soften or fade se-
lections, the rule of thumb is to look around at objects 
in nature. Object edges rarely appear absolutely crisp 
and sharp. Applying a slight feather almost always 
looks more realistic — try even a 0.5 pixel feather.

Move selected content. Use the Move tool to 
relocate the content within the current layer or be-
tween documents. Alt/Opt+Move copies selections.

Copy/cut and paste. Use the Clipboard to 
relocate content within the current document or to 
another document. Pasting puts the Clipboard on 
a new layer. Pasting into a selection applies a layer 
mask in the shape of the selection.

Edit selected content. Change the content. 
Create a new layer, and paint in the selection. Create 
adjustment layers and masks based on the selection 
for isolated color correction. Run fi lters on selected 
areas or on masks.

Deselecting and reselecting a selection. 
Choose Select > Deselect or click anywhere on the 
canvas outside the selected area to deselect a selec-
tion. To reselect the last selection, choose Select > 
Reselect. If the last action was to deselect a selection, 
you can also choose Edit > Undo.
Selecting a Layer or Its Contents

A selection isolates pixels in only the cur-
rently selected-or active-layer. Therefore, be sure 
that you fi rst select the specifi c layer that you 
want to edit. When layers contain transparent 
areas or objects that do not take up the entire 
layer, you need not reselect their pixels before 
using selection tools. Photoshop allows you to 
quickly select a layer’s contents at the same time 
you make the layer itself active for editing. You 
can select a layer in the following ways:

In the Layers palette, click the layer’s thumb-
nail or title. The layer is highlighted with a brush 
icon in the left column to indicate it is active. Or, 
with the Move tool selected, Control/right-click in 

the canvas over the content you want to select. 
A contextual menu appears listing all the layers 
with content currently under the mouse cursor. 
Select the desired layer from the list. You can 
temporarily toggle to the Move tool from any 
active tool by pressing the Command/Ctrl key. 
This is not to be mistaken for selecting pixels or 
layer content. If you do not select any specifi c 
content in the layer using the techniques shown 
in the rest of this series of articles, your actions 
or changes are applied to the entire layer.

To select only the opaque pixels of the layer 
and exclude all transparent pixels, do one of the 
following: 

· Command/Ctrl-click the layer in the Layers 
palette. 

· Control/right-click a layer thumbnail in the 
Layers palette and choose Layer Transparency 
from the contextual menu. 

· If you Choose Select > All on a layer con-
taining transparent areas, a marquee will appear 
around the entire canvas. If the content of the 
layer is moved, the selection marquee snaps 
to the boundary of the object or pixels on the 
layer. 
Selecting Rectangular or Elliptical 
Areas

A common way to make a simple selection 
is to use the marquee tools, which allow you to 
select a regular rectangular or elliptical region 
of the canvas. Making such a selection is often a 
helpful way to begin a more complex selection or 
to defi ne the area to begin an edit. For example, 
if you are creating a rectangular button, select a 
rectangular area to defi ne the size of the button 
and then begin to edit the selection. To use the 
marquee tools, follow these steps: 

1. Select a layer. 
2. Choose a marquee tool from the Tool-

box:
Rectangular Marquee
Elliptical Marquee
Single Row Marquee
Single Column Marquee
3. Set the options in the tool options bar for 

this selection: 
o Choose how the new selection should 

be treated in relation to the current selection: 
deselect the current selection and start a new 
selection, add to the current selection, subtract 
from the current selection, or intersect with the 
current selection. 

o If you are using the Rectangular Marquee 
or Elliptical Marquee tool, enter the amount of 
feathering for the new selection (0 is no feath-
ering), specify whether you want the selection 
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anti-aliased so that edges are softer, and choose 
a style for the selection (Normal, Fixed Aspect 
Ratio, or Fixed Size). 

o If you select Fixed Aspect Ratio or Fixed 
Size, enter an aspect ratio or width and height. 

4. Depending on the marquee tool and op-
tions selected, do one of the following: Rect-
angular or Elliptical Marquee. Click and drag 
diagonally across the area you want to select. 
Single Row, Single Column, or Fixed Size 
Marquee selections. Click in the image to se-
lect, and drag to position the marquee. 

5. You can now refi ne the selection further 
or edit the selection. 

Selecting and Moving Image Content: 
Part 2

Creating Free-Form and Color-Based Selec-
tions
Creating Free-Form Selections

To capture irregular 
shapes, your primary op-
tions are the three free-
form lasso tools, or you can 
use a Quick Mask to “paint” 
the area to be selected. In 
the fi rst illustration, you can 
see the irregular edges of 
the sunfl ower as selected 
with the Lasso tool. In the 
next illustration, note the 
straight edges of the barn 
roof as captured with the 
Polygonal Lasso tool. You 

can use the Lasso and Polygonal Lasso tools 
to freehand trace the 
outline of the area you 
want to select. Follow 
these steps:

1. Select a layer. 
2. Choose the Las-

so or Polygonal Lasso 
tool. 

3. Set the options 
in the tool options bar 
for the selected tool: 

o Choose how the new selection should be 
treated in relation to the current selection. 

o Enter the amount of feathering for the new 
selection (0 is no feathering). 

o Specify whether you want the selection 
anti-aliased so that edges are softer. 

4. Depending on the Lasso tool selected, do 
one of the following:

Lasso. Click and drag around the area you 
want to select. When you release the mouse 
button, the selection is automatically closed by 

a straight line between the starting and stopping 
points.

Polygonal Lasso. Click at points around the 
area you want to select to create straight sides. 
To close the selection, click back on the fi rst point. 
(The Polygonal Lasso icon appears with a circle 
next to it when you are over the point.) You can 
also Command/Ctrl-click or double-click to close 
the selection with a straight line between the 
starting and stopping points.
Using the Magnetic Lasso Tool

The Magnetic Lasso tool goes one step fur-
ther than other lasso tools by reading the image 
content you are trying to select and automatically 
sticking to edge contours as you move along with 
your cursor-so you don’t have to work quite as 
hard to follow exact edges. Photoshop does this 
by looking at the contrast between areas where 
you drag your cursor to determine where the 
edge boundary should be. The results are not 
always perfect, and you will need to adjust the 
options for some objects, but this technique can 
save a lot of time-particularly if you have clear 
defi nition between shapes:

1. Select a layer. 
2. Choose the Magnetic Lasso tool. 
3. Set the options in the tool options bar for 

this selection tool: 
o Choose how the new selection should be 

treated in relation to the current selection. 
o Enter the amount of feathering for the new 

selection (0 is no feathering) 
o Specify whether you want the selection 

anti-aliased so that edges are softer. 
o Enter the width from the mouse pointer to 

be considered as part of the path. If the image 
is high contrast, use a wide line to ensure a solid 
edge. If there are a lot of small shapes, use a 
width larger than 10 pixels. 

o Enter the percentage of contrast between 
edges in the image to be considered for the path. 
Use a high percentage for high-contrast images 
to ensure a tighter fi t. 

o Under Frequency, enter a number (1 
through 100) for how often anchor points are 
automatically added along the path. The more 
points, the tighter the fi t, but the more jagged 
the selection may appear. 

o If you are using the Magnetic Lasso tool 
and a tablet, specify whether you want to allow 
pen pressure to set the width. 

4. Click to set the fi rst anchor point in the 
selection, and then drag around the edge of the 
object you are attempting to select. A selection 
path (a solid line) snaps to the edge of the ob-
ject as you drag. Your settings for Width, Edge 
Contrast, and Frequency determine how the tool 
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reads edges and fi ts your selection.
If you notice that the selection is moving 

away from the desired edge, try moving more 
slowly. You can only back up to the last anchor 
point. Click to manually add anchor points if you 
are on track, and then continue your selection. 

5. To close the magnetic selection, do one of 
the following:

· C l i c k 
back on the fi rst 
point. (The Mag-
netic Lasso icon 
appears with a 
circle next to it 
when you are 
over the point.) 

· C o m -
mand/Ctrl-click, 
press Return/En-
ter, or double-
click to close the 
selection with a 

magnetic path line directly between the starting 
and stopping points calculated by Photoshop. 

· Option/Alt-double-click to close the selec-
tion with a straight line between the starting and 
stopping points. 
Using Quick Mask to Make a Selection

Using Quick Mask is a unique alternative 
to other selection methods. Rather than having 
to trace the border of a desired selection, you 
can use painting tools to make your selection. 
Quick Mask mode is based on the process used 
for editing any mask or channel in Photoshop-
painting with black or white to add or remove 
masked areas-with the added convenience of 
toggle buttons in the Toolbox to quickly switch 
between mask and selection. Quick Mask is also 
unique in that it offers you a color overlay, which 
by default simulates a Rubylith channel and works 
as an onionskin layer that you can manipulate 
independently of the image itself, allowing you 
to use tools to “draw” your selection as an alpha 
channel. You can switch to Quick Mask any time 
from any selection to edit or make changes. You 
can create great, quick, rough selections or intri-
cately detailed selections that might otherwise be 
diffi cult using this technique. To use Quick Mask 
to make a selection, follow these steps:

1. Choose the Quick Mask Mode option on the 
toolbar. Your foreground and background colors 
are switched to black and white. 

2. Choose any appropriate size and shaped 
brush to paint areas you want to select. It will ap-
pear as though you are painting-on a semitrans-
parent layer. In the illustration at right the mask 
is being painted over the image (indicated here by 

lighter areas). 
The mask will 
appear as a 
s em i t ran s -
parent red or 
mock-Rub -
ylith by de-
fault. Toggle 
between fore-
ground and 
background 
colors (black/
white) to al-
ternate be-
tween adding 
and subtract-

ing from the mask. 
3. After you paint your mask, select the 

Standard Mode button in the toolbar to turn the 
mask into a selection. Click back to Quick Mask 
mode to turn the current selection back into a 
mask and continue editing. 

When making precise selections, it is helpful 
to zoom in to the image as much as possible to 
see greater detail. To help make Magnetic Lasso 
selections, increase the difference between edges 
in the image by adding a Brightness/Contrast 
fi ll layer and increasing contrast. Double-click 
the Quick Mask icon in the Toolbox to set Quick 
Mask options. You can switch between painting 
masked versus selected areas and change the 
color and opacity of the overlay. Though you can 
make selections with Feathering preset, you may 
fi nd it advantageous to make selections fi rst and 
then add feathering and try different settings for 
your specifi c conditions. 

Photoshop’s Magic Wand tool and the Select 
> Color Range menu option allow you to make 
selections based on image or pixel color. You can 
take advantage of large areas of similar color for 
easy selections, or you can select bits of the same 
color that are scattered in your image to save 
time. If the area you want to select contains lots 
of tonal changes, you might have to play with 
your settings to get the desired selection. 
Using the Magic Wand Tool

You can use the Magic Wand tool to click a 
single pixel in your image to select that color 
and similar colors immediately surrounding it or 
throughout the image. Follow these steps: 

1. Select a layer as described in the previous 
installment. 

2. Choose the Magic Wand tool. 
3. Set the options in the tool options bar for 

this selection: 
o Enter the color tolerance (0 through 255) 

for the selection. This number specifi es how 
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similar a color has to be to the color clicked to be 
included in the selection. The higher the number, 
the more tolerant the selection. 

o If checked, anti-aliasing is used to give the 
edges of the selection a smoother appearance. 

o If Contiguous is checked, only pixels touch-
ing the selected pixel and within the set tolerance are 
included in the selection. Otherwise, the Magic Wand 
tool selects all pixels in the image within the tolerance 
level. 

o If Use All Layers is checked, the Magic Wand 
selects pixels on all layers in the image. Otherwise, the 
Magic Wand tool works only within the selected layer. 

4. In the canvas, click a pixel of the color you want 
to select. You can change the Tolerance setting you have 
chosen or simply Shift+click to add to your Selection. 

Below at left, a Magic Wand selection with a Toler-
ance of 25 and Contiguous checked. The selection is 

stopped by the 
black line. 

At right, 
a Magic Wand 
selection with a 
Tolerance of 150 
and Contigu-
ous unchecked. 
More pixels are 
selected, and 
the selection is 
not stopped by 
the black line. 

Using the Color Range Dialog
You can choose Select > Color Range to 

make simple color-based selections or to make 
complex selections reading color subsets and 
blends: 

1. You can fi rst limit the area being consid-
ered by making a selection. 

2. Choose Select > Color Range to open the Color 
Range dialog. 

3. Click with the Eyedropper on a desired color, 

and drag the slider in the dialog. Experiment with 
various settings and combinations:

A - Choose to select colors directly from the im-
age or to select a particular color, luminosity, or out-
of-gamut colors.

B - Click to enter or use the slider to set the level 
of fuzziness (0 through 200), which is much like color 
tolerance.

C - Preview. Shows the image, the selected area 
(white indicates a selected area), or a reduced version 
of the original image.

D - Choose a preview method for the canvas, 
showing the selection either as grayscale (shown) or 
the full image.

E - Click to load previously saved settings.
F - Click to save the current settings.
G - Eyedropper tool. Click to select a new color. 

This action deselects other colors currently selected.
H - + Eyedropper tool. Click to select a color to 

add to the current range (Shift+click).
I - - Eyedropper tool. Click to select a color to 

remove from the current range (Opt/Alt+click).
J - If checked, the selection is inverted.
K - Choose a method for previewing the selection 

in the canvas : None, Grayscale, Black Matte, White 
Matte, Quick Mask.

L - Use the Eyedropper tool to select colors in the 
preview area, in the document windows, or from any 
color swatch in the interface.

4. When you are satisfi ed with the preview, click 
OK.

5. Check what you’ve got with the next desired 
command. Undo, make adjustments to the dialog 
options, and make repeated selections with alternate 
variables. This is one of those tools that require ex-
perimentation.
Increasing or Reducing Selection 
Areas

After making an initial selection, you can 
add to or subtract from the selection in a variety 
of ways. The following modifi ers appear at the 
left side of the Options bar when you choose a 
selection tool from the Toolbox:

A - New Selection
B - Add To Selection
C - Subtract From Selection
D - Intersect Selections 

Using Selection Tools to add to or 
subtract from a Selection

You can use all the selection tools (Marquee, 
Lasso, and Magic Wand) to add to or subtract 
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from an existing selection. Depending on the tool 
you are using, the cursor icon will have a plus 
(+) next to it when adding or a minus (-) when 
subtracting. You can add or subtract using the 
selection tools in two ways: 

· Choose a selection tool, and then click 
the Add To Selection or Subtract From Selection 
button in the tool options bar. Set other options 
for the selection tool as desired, and then follow 
the instructions for selecting with that tool. The 
new selection is added to or subtracted from the 
original selection. 

· Choose a selection tool, set options in the 
tool options bar, and then hold down the Option/
Alt (subtract) or the Shift (add) key while follow-
ing the instructions for selecting with the current 
tool. The new selection is added to or subtracted 
from the original selection. 

In the illustrations below, the one at left 
shows the original selection (square) and the 
new selection. On the right, the new selection 
has been added to the original selection. Bott-
tom, the new selection has been deleted from 
the original selection.

 Use selection tools to select the common 
area between an existing selection and a new se-

lection. When you 
are creating an in-
tersection, the cur-
sor icon will have 
an X next to it. Fol-
low these steps: 

1. Choose 
a selection tool, 
click the Intersect 
button, and set the 
other options in 
the tool options 
bar. 

2. Follow the instructions for the tools being 
used to make a second selection. Make sure that 
the new selection overlaps the existing selection; 
if it does not, no pixels will be selected. 

Don’t confuse inverting the selection (the 
Inverse command) with inverting colors. The 
two processes have similar names and keyboard 
shortcuts, but produce very different results.
Switching Selected and Unselected 
Areas

Often it is easier to select the area that you 
do not want selected than the area you want 
selected. For example, it is easier to select a fl at, 
colored background that surrounds a complexly 
shaped object rather than trying to select the 
object itself. In these cases, you then need to 
invert the selection to select the desired area. 
First make a selection, and then choose Select 
> Inverse. You can then refi ne the selection 
further or edit the selection. In the illustration 
at right, the selection has been inverted. Notice 
that the selection marquee follows the edges of 
the canvas. 
Feathering a Selection

Photoshop gives you numerous options for 
modifying selection edges, from convenient op-
tions for adding and subtracting pixels to soften-
ing or feathering selections. Feathering is the pro-
cess of softening the edges of a selection, making 
a gradual fading transition from the boundary of 
the selection inward. You can set feathering as 
an option in the tool options bar before making 
most selections (except with the Magic Wand), 
but you can also set feathering after making a 
selection. Follow these steps:

1. Choose Select > Feather…. 
2. Enter the number of pixels you want to be 

feathered from the edge of the selection marquee 
in the Feather Selection dialog. The number you 
choose depends not only on the amount of fade 
you want, but also on the size of the actual se-
lection and the resolution of the image. 

3. Click OK. The selection is now feathered 
at the edges. 

The content around the center of the im-
age at left has been selected and feathered. 
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You can really see the effects of the feathering 
when the selection is deleted, as shown in the 
image at right. Don’t confuse moving the selec-
tion marquee with moving the selected content. 
You can move the marquee using any selection 
tool, and doing so does not affect the image. You 
can move the selected content only by using the 
Move tool. 
Enlarging a Selection Based on Color

To enlarge an existing selection based on 
similarities in pixel color you can:

Add contiguous pixels. Choose Select > 
Grow to expand the selection to include colors 
immediately around the image based on the 
selected area and within the set tolerance in the 
Magic Wand options.

Add noncontiguous pixels. Choose Select 
> Similar to expand the selection to include col-
ors throughout the image based on the selected 
area and within the set tolerance in the Magic 
Wand options. 

At left, the original selection to be modifi ed. 
In the middle, Grow: the selection grows to in-
clude similar pixels in the same area. At right, 
Similar: the selection includes similar pixels 
throughout the image. 

Modifying a Selection
To capture an exact area, you must use a 

variety of methods to make your selection and 
then further refi ne and modify the selection. You 
can continually modify selections at any time 
while working with them. At left, the original se-
lection to be modifi ed, in the middle a 10-pixel 
border is selected, while at right the selection is 

smoothed to 20 pixels. 
Photoshop offers you four basic selection 

modifi ers. 
To select a border based on a selection. 

Choose Select > Modify > Border…, enter the size 
of the desired border, and click OK. The selection 
is changed to a border of the set thickness around 
the position of the original border.

How To smooth a rough selection. Choose 
Select > Modify > Smooth…, enter the amount 
of smoothing you want (higher numbers create 
smoother selections), and click OK. The selection 
will fl atten sharp picks and dips within a jagged 
selection by the amount you indicated. Smooth 
is most effective in RGB mode.

How To enlarge the size of the selection. 
Select > Modify > Expand…, enter the number of 
pixels to enlarge the selection, and click OK.

How To reduce the size of the selection. 
Choose Select > Modify > Contract…, enter the 
number of pixels by which to reduce the selec-
tion, and click OK.

Selection marquees that have been feath-
ered have rounded edges at the corners. To avoid 
the clipping or rounding of corners associated 
with expanding and contracting selections, you 
can switch to Quick Mask and choose Filter > 
Other > Maximum or Filter > Other > Minimum. 
At left, the selection is expanded by 10 pixels, 
at right it’s contracted by 10 pixels.

Moving the Selection Marquee
You can move the selection marquee inde-

pendently of the actual image content, which al-
lows you to make a selection in one layer or area 
and then transfer the selection to another layer 
or area without affecting the content. At left, the 
selection is moved, but the content remains in 
the same place. Warning: Don’t confuse invert-
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ing the selection (the Inverse command) with 
inverting colors. The two processes have similar 
names and keyboard shortcuts, but produce very 
different results. 

· To move the selection marquee within a 
layer, choose any selection tool and select the 
New Selection button in the tool options bar. 
Now either click and drag anywhere within the 
selection or use the arrow keys to move the se-
lection. 

· To move the selection marquee to another 
layer, simply select the target layer using one of 
the methods discussed in earlier articles. 

· To move the selection marquee between 
open Photoshop documents, choose any selection 
tool and select the New Selection button in the 
tool options bar. Now click anywhere within the 
selection and drag it from the original document 
into the target document’s canvas. The selection 
is placed into the currently selected layer of the 
target document. The selection marquee is still 
available in the original document as well. 
Transforming the Selection Marquee

You can transform a selection marquee: you 
can scale it, skew it, distort it, and add perspec-
tive to it. You transform a selection marquee on 
a bounding box in much the same way that you 
transform content, but only the selection mar-
quee is affected, not the selected content. To 
transform the selection marquee, follow these 
steps: 

1. Choose 
Select > Transform 
Selection to display 
a rectangular bound-
ing box around the 
entire selection. 

2. Make one 
or more of the follow-
ing transformations 
to the marquee: 

· To move 
the entire selection 
marquee, click and 

drag within the bounding box except at the exact 
center. 

· To adjust the reference point (which sets the 
center for transformations), click and drag it to the 
desired location. 

· To scale the selection marquee, click and drag 
an edge of the bounding box. Click corner points to 
resize both horizontally and vertically at the same 
time. 

· To symmetrically scale the selection marquee 
around the reference point, Option/Alt-click and drag 
an edge or a corner point of the bounding box. 

· To rotate the selection marquee around the 

reference point, click and drag just outside the 
bounding box. 

· To skew the selection marquee, Shift-
Command-click/Shift-Ctrl-click and drag an edge 
of the bounding box. 

· To distort the selection marquee, Com-
mand/Ctrl-click and drag any of the edges or cor-
ner points of the bounding box independently. 

· To symmetrically distort the selection 
marquee around the reference point, Option-
Command-click/Alt-Ctrl-click and drag edges or 
corner points of the bounding box. 

· To add perspective to the selection mar-
quee, Control/right-click and select Perspective 
from the contextual menu. Click and drag on an 
edge or a corner point to change the selection’s 
perspective. 

3. Click the Commit button in the tool options 
bar or press Enter/Return to accept the transfor-
mations. Click the Cancel button or press Esc to 
cancel transformations and leave the selection 
unchanged. 
Saving a Selection

Although many of the selections you make 
will be temporary, you may also fi nd that mak-
ing precise selections takes considerable effort. 
Preserving selections to save yourself work in 
redoing them — should you change your mind or 
consider another option down the road — might 
just become part of your routine one day. You 
can save selections for use between documents; 
this is particularly helpful in production work or 
running actions on multiple images. To save a 
selection, follow these steps: 

1. Make a selection. 
2. Choose Select > Save Selection…. 
3. Set options in the Save Selection dialog. 

A - Specify whether you want the selection 
saved in the current document, an open docu-
ment duplicated from this document, or a new 
document.

B - Select an existing channel to save the 
selection in, or choose to save the selection in a 
new channel. If you are creating a new document, 
New will be the only choice for channel.
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C - If you are creating a new channel for the 
selection, enter its name.

D - If you are adding the selection to an ex-
isting channel, choose the operation for how the 
new selection should be placed in the channel. 

4. Click OK. 
· If you choose to start a new document, 

an untitled document is opened with the new 
channel. 

· If you choose to add the selection to an-
other channel, the selection is now a part of that 
channel. 

· If you choose to start a new channel for 
the selection, the channel is added to the docu-
ment in the Channels palette. 
Loading a Selection

To load a selection, follow these steps: 
1. Select a layer into which to load the selec-

tion. You can also make an initial selection. 
2. Set options in the Load Selection dialog. 
3. Click OK. The new selection is on the canvas. 

A - Choose the open document you want with 
the desired selection channel.

B - Choose the channel from which to load 
the selection.

C - Check to invert the selected area.
D - If you have an existing selection already 

on the canvas, choose the operation for how the 
new selection should be treated in relation. 
Loading a Selection from the Channels 
Palette

You can also reload selections directly from 
the Channels palette. Save a selection as an alpha 
channel, bypassing the Save Selection dialog, by 

clicking the Save Selection As Channel button.
A - Highlight the alpha channel that contains 

the selection.
B - Load the channels as selections.
C - Save the selection as a channel. 
1. In the Channels palette, click the alpha 

channel that contains the saved selection. The 
canvas will show the black and white of the alpha 
channel. White is the selected area. 

2. Click the Load Channel as Selection but-
ton [ButtonSelectToPath.tif]. The selection will 
be displayed in the canvas. Select the Combined 
channel to view the image again. 

After copying, pasting, extracting, or oth-
erwise isolating an object or image content, 
you may fi nd yourself wanting to manipulate 
it-wanting to transform it-to better fi t your in-
tentions or its surroundings. Photoshop allows 
you to transform content by scaling, skewing, 
distorting, or adding perspective to the selected 
object or layer.

You can apply transformations using menu 
commands or by using transformation pseudo 
tools. Accessed via menu command, these pseudo 
tools allow you to intuitively drag control points 
(C) on a bounding box (A) displayed around the 
content being manipulated. Several transforma-
tions use a movable reference point (B) on which 
they base their transformation. Click and drag 
this icon to reposition the reference point. For 
example, a Rotate command will rotate around 
this reference point. You can also reposition 

Top Left: Scale, adjust from corners. Add Shift to constrain. 
Top Right: Skew, sides adjust and remain parallel. 
Bottom: Distort, adjust from sides and corners. 
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content while transforming. In all the following 
examples, the original silhouette at 65% opacity 
is copied and the duplicate transformed to give 
you a reference for what was done.

Using the Free Transform Pseudo tool
The most common way to make transforma-

tions is to use the Free Transform pseudotool, 
which allows you to make any of the transforma-
tions. Which transformation you make depends 
on where you click or which keyboard or menu 
modifi ers you choose. To use the Free Transform 
pseudo tool, follow these steps: 

1. Select a layer to transform. You can also 
select specifi c content on the layer. If no content is 
selected on the layer, the transformation is applied 
to the entire layer. 

2. Choose Select > Transform Selection to dis-
play a rectangular bounding box around the entire 
selection. 

3. 
4. Make one or more of the following transfor-

mations: 
o To move the entire selection, click and drag 

within the bounding box. 
o To adjust the reference point (which sets the 

center for transformations), click and drag it to the 
desired location. 

o To scale the selection, click and drag an edge 
of the bounding box. Click corner points to resize 
both horizontally and vertically at the same time. 

o To symmetrically scale the selection around 
the reference point, Option/Alt-click and drag an 
edge or a corner point of the bounding box. 

o To rotate the selection around the reference 
point, click and drag just outside (but not touching) 
the bounding box. 

o To skew the selection, Shift-Command-click/
Shift-Ctrl-click and drag an edge of the bounding 
box up or down. 

o To symmetrically skew the selection, Option-
Command-click/Alt-Ctrl-click and drag an edge of 
the bounding box up or down. 

o To distort the selection, Command/Ctrl-click 
and drag edges or corner points of the bounding 
box. 

o To symmetrically distort the selection around 
the reference point, Option-Command-click/Alt-
Ctrl-click and drag edges or corner points of the 
bounding box. 

o To add perspective to the selection, Con-
trol/right-click and select Perspective from the 
contextual menu. Click and drag an edge or a 
corner point to change the selection’s perspec-
tive. 

5. Click the Commit button in the tool options 
bar or press Enter/Return to accept the transfor-
mations. Click the Cancel button or press Esc to 
cancel transformations and leave the selection 
unchanged. 

Top Left: Perspective, adjust from sides and corners. 
Top Right: Rotate, with reference point shifted off 
center. 
Bottom: Flip, horizontal with reference point shifted 
off center.
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Using Commands and Pseudo tools
You can also access each transformation pseudo tool 
independently on the Transform submenu. This allows 
you to focus on making one kind of transformation 
without worrying about whether you have your mouse 
in the right position or the right keyboard modifi er 
pressed. To transform using commands and pseudo 
tools, follow these steps: 

1. Select a layer to transform. You can also 
select specifi c content on the layer. If no content 
is selected on the layer, the transformation is 
applied to the entire layer. 

2. Choose Edit > Transform and then one of 
the options in the submenu. You can select dif-
ferent pseudo tools to work with while making 
transformations, using either the Edit > Trans-
form menu or the contextual menu. 

Again. Choose to repeat the previous trans-
formation. 

Scale. Choose to use the Scale pseudo tool. 
Click and drag an edge of the bounding box to 
resize. Click corner points of the bounding box to 
resize both horizontally and vertically at the same 
time. Press Option/Alt to scale symmetrically. 

Rotate. Choose to use the Rotate pseudo 
tool. Click and drag just outside the edges of the 
bounding box to freely rotate the selection. 

Skew. Choose to use the Skew pseudo tool. 
Drag an edge of the bounding box up or down to 
skew. Press Option/Alt to skew symmetrically. 

Distort. Choose to use the Distort pseudo 
tool. Drag edges or corner points of the bounding 
box. Press Option/Alt to distort symmetrically. 

Perspective. Choose to use the Perspective 
pseudo tool. Click and drag an edge or a corner 
point to change the perspective. 

Rotate 180°, 90° CW, or 90° CCW. 
Choose to turn the entire selected region. 

Flip Horizontal Or Vertical. Choose to re-
verse the area in the indicated direction. 

3. Click the Commit button in the tool options 
bar or press Enter/Return to accept the transfor-
mations. Click the Cancel button or press Esc to 
cancel transformations and leave the selection 
unchanged. 
Using the Transform Tool Options Bar

Even though they are not real tools (at least 
they are not in the Toolbox), all transform pseudo 
tools have options in the tool options bar that 
allow you to make transformations numerically. 
Follow these steps: 

1. Select a layer to transform. You can also 
select specifi c content on the layer. If no content 
is selected on the layer, the transformation is 
applied to the entire layer. 

2. Select a transform pseudo tool from the 
Edit > Transform submenu, or choose Edit > Free 
Transform. 

3. Set the options in the tool options bar.

A - Reference Point Location. Click one 
of the open squares to set the relative position 
of the reference point in relation to the bound-
ing box. 

B - Reference Point Horizontal and Ver-
tical Position. Enter an exact position for the 
reference point in the canvas. 

C - Use Relative Position For Reference 
Point. Click if you want the units for horizontal 
and vertical to show the position of the reference 
point location relative to its initial location. 

D - Set Horizontal and Vertical Scale. 
Enter the width and height (as percentages) for 
the bounding box. 

E - Link Scales. Click if you want the hori-
zontal and vertical values to remain relative to 
each other. 

F - Set Rotation. Enter a value (-180 
through 180) in degrees to specify the angle of 
the selection. 

G - Set Horizontal And Vertical Skew. 
Enter values (-180 through 180) in degrees to 
specify the amount of twist to be applied to the 
selection. 

H - Cancel Transformation. Click to reject 
transformation changes. 

I - Commit Transformation. Click to accept 
transformation changes. 

Moving selected content may sound like a 
primary function in Photoshop, yet the logistics 
are most often carried out in a less straightfor-
ward way-copying and pasting, extracting or 
deleting backgrounds, and then moving objects 
and layers as opposed to moving selected con-
tent. Moving selected content between images 
is both a memory- and a time-saver. Copying 
while moving (dragging) selected content is an 
oft-overlooked tool in photo retouching.
Dragging and Dropping Content

Once an area has been selected, you can use 
the mouse cursor to drag the selected content 
anywhere on the document’s canvas (or even to 
a different document) and drop it in a new loca-
tion. This is not as important on most computers 
today, but this process is less memory-intensive 
than copy and paste. The content in the image 
to the left is being moved across the screen. To 
drag and drop content, follow these steps: 

1. Select an object or specifi c content you 
want to move. If no content is selected on the 
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layer, the entire layer is moved. 
2. Choose the Move tool. 
3. Do one of the following: 
o To move the content to another open Pho-

toshop document, click within the selection and 
drag it to the canvas of the target document. 
The content is placed in a new layer immediately 
above the previously selected layer. This will not 
remove the content from the originating docu-
ment. Hold down the Shift key to center pixels 
in the new layer. 

o To move the content to another applica-
tion, fi rst make sure that the application will ac-
cept graphic input. If it does, open a document 
in that application, switch to Photoshop, click 
within the selection, and drag it to the document 
window of the target application. 

o To move the selected content within the 
same layer, simply click within the selection and 
drag the content to the desired position. You can 
continue to move the selected content without 
dropping it until you deselect it or select another 
layer. The content being moved will leave a hole 
in the layer, either transparent or fi lled with back-
ground color. 
Dragging and Dropping from another 
Application

Photoshop can also receive input from other 
applications. To drag and drop from another ap-
plication, do one of the following: 

o To move a bitmap image, click the image in 
the application and drag it into the canvas of an 
open Photoshop document. The content is placed 
in a new layer immediately above the previously 
selected layer. 

o To move a vector image from Illustrator, 
select the vector image(s) and drag into an open 
Photoshop document window. The unrasterized 
vector image appears on a new layer with a 
bounding box to which you can apply transfor-

mations, or you can specify options in the tool 
options bar. Click the check mark or press Enter 
to render the vector image at the image’s resolu-
tion. 

o To move text, select the text and click and 
drag it to an open Photoshop document window. 
The text is rasterized at the image’s resolution. 
To move as text, you need to copy and paste it 
into a text layer. 
Drag-Copying a Selection

If you are duplicating an object within the 
same layer, simply copy it while dragging to its 
target location to save time. This is an invaluable 
way to remove blemishes quickly. Follow these 
steps: 

7. Select the layer with the content to be 
duplicated, and then select specifi c content on 
that layer. 

8. Choose the Move tool, and then, in the 
canvas, Option/Alt-click and drag. One of two 
things will happen: 

§ If you selected a layer, the content of the 
layer is duplicated into a new layer. 

§ If you selected content within a layer, the 
content is duplicated as a selection on the same 
layer. 

9. When you release the Move tool, the dupli-
cated content is set. The original content remains 
in its initial position. 

Press Option/Alt and drag a selection (left) 
to duplicate it while moving (right).
Copying and Cutting Selected Content

Whether you copy or cut, you are actually 
placing information in temporary memory on the 
Clipboard. Just as in other applications with which 
you might be familiar, cutting removes selected 
information, and copying duplicates the selected 
information-in Photoshop this information can be 
pixels, vector information, or text. When copying 
pixels in Photoshop, you can either copy what is 
on a selected layer or copy all of what you see in 
a selection (and below it) by copying “merged” 
pixel information.

Content is moved to the Clipboard whenever 
you copy or paste a layer or a selected part of a 
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layer, but only one selection at a time, and every 
time you copy or paste, the previous selection 
is replaced in the Clipboard. However, you can 
paste this selection from the Clipboard as many 
times as desired. To move selected content to 
the Clipboard, do one of the following. 

o Choose Edit > Copy to move the selected 
content to the Clipboard but leave the original 
intact. 

o Choose Edit > Cut to move the selected 
content to the Clipboard and delete the origi-
nal. 

o Choose Edit > Copy Merged to move the 
selected content on all layers to the Clipboard. 

A portion of the image or layer is selected 
(left). Copying will have no visible effect on the 
image. Cutting, however, will leave a hole (or fi ll) 
in place of the selected content (center). On a 
Background layer, the fi ll will be in the color speci-
fi ed as the background color in the Toolbox. When 
you copy and immediately paste the selection in 
the same document, it is positioned exactly above 
where it was. If you choose to cut and paste, the 
pasted selection will not be aligned (right).
Pasting in Place

Pasting content in Photoshop is generally the 
second half of a process, as you must fi rst have 
content in your Clipboard-copied from within a 
Photoshop document, from another application, 
or from the operating system as with a screen 
capture. With content already copied, you have 
several options. What you paste depends on the 
resolution of the original. 

If you are copying and pasting in the same 
document, without deselecting, your copied 

content will be pasted in the same position as 
the original... on a new layer directly above the 
original content. As soon as you deselect the 
area from which you are copying, the informa-
tion on the Clipboard is document independent 
and is treated just as if you were working in a 
new document. 
Pasting to another Document

To paste the content of the Clipboard into a 
different document, open the document and then 
do one of the following: 

o Choose Edit > Paste. The image in memory 
is placed in the middle of a new layer, inserted 
immediately above the active layer in the selected 
document. 

o Make a selection and choose Edit > Paste. 
The image is placed in a new layer, centered over 
the selection area. 

o Make a selection and choose Edit > Paste 
Into. The image is placed in a new layer above 
the active layer, centered in and masked by the 
selection. 
Pasting from another Application

You are not limited to copying and pasting 
just within Photoshop. You can also copy images 
(bitmap and vector) or text in or from other 
applications and then paste that content into a 
Photoshop document. Pasting from another docu-
ment depends more on where and how you copy 
the content than on the pasting itself. 

o Generally, pasting from another applica-
tion is as described in the previous section. Your 
resolution depends on the source document and 
application. 

o Pasting text requires you to choose the 
Type tool, create a text box, or insert your cursor 
in the document and paste. You can set format-
ting before or after pasting. 

o If you are not getting the results or reso-
lution you need from the copy-and-paste pro-
cess, explore the (other) application’s export 
formats. 
Pasting a Vector Image from Another 
Application 

Photoshop allows you the option of preserv-
ing vector information (paths) you copy from 
other applications. You can also allow Photoshop 
to convert or transform the vector data from 
your Clipboard into pixels or vector shapes. Vec-
tor paths from other applications can be edited, 
fi lled, stroked, turned into shape presets, and 
printed from Photoshop with PostScript charac-
teristics intact. When you paste a vector image 
selected and copied from another application 
such as Adobe Illustrator, you are presented with 
a dialog that gives you three choices: 



PS848 - MOVING AND SELECTING IMAGE CONTENT                          14 N/08/08

The art is selected and copied (top left) from 
Adobe Illustrator. The Paste dialog (center) gives 
you the choices for pasting as Pixels, Path, or 
Shape Layer. If you select either Path or Shape 
Layer, you create a work path or a vector mask 
(right).

If you paste the vector art as pixels (bot-
tom), it will be surrounded by a bounding box so 
that you can scale it as vector information one 
last time before rasterizing into pixel data. If the 
vector art is pasted as paths (center), the paths 
can be resized, stroked, or fi lled. You can save 
the path using the Paths palette. If you paste 
the vector art as a Shape layer (right), the paths 
take on a fi ll in the selected foreground color; 
notice that you also loose all detail in the vector 
artwork.

Each of the options available in Photoshop 
for pasting vector artwork has distinct creative 
or design possibilities, from print considerations 
to future use and versatility. For example, you 
can paste a company logo or a vector signature 
into Photoshop and use it repeatedly as a custom 
shape. All the color and detail of complex vector 
artwork can be further stylized with tools avail-
able in Photoshop that are not generally available 
in vector-editing applications.


