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With a few free tools from software companies and other users, you can carve out more
time for what you really love -- creativity.

There are no prizes for guessing which of the following most creatives would plump for:
investigating ways to increase efficiency, or exploring new design ideas and techniques.

Being creative is what designers love most about the profession, yet if we were to
break down an average working week into creative and non-creative activities, most of us
would be slack-jawed in surprise.

Once you subtract the time lost to performing repetitive tasks -- such as mousing
around OS and application menus, shunting palettes about, performing multiple file con-
versions, switching from app to app, and managing arcane document workflows -- not
much time is left for designing that new logo or magazine dummy.

Being efficient is not a crime against creativity, and yet many designers disparage it;
efficiency, | was once told by a design co-worker, "is for production monkeys."

Let's discard that self-defeating view. The more time we can spend being creative,
the better for both us and our clients. In recognition of that truth, Adobe has made pro-
ductivity a key plank of its Creative Suite. Here are five primary ways in which the CS apps
can help you be more efficient.
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Desired Result Keyboard Shortcut
. Keyboard Shortcuts
New File Command/Control + N .
: Why scroll through menus for everything,
Open File Command/Control + 0 . . .
a c T7c | when learning keyboard shortcuts is so much quick-
e ommand/Control+W | o5 Keyboard commands take a fraction of a second,
Q"_‘" Command/Contrel +Q | h;t mousing to a menu item takes, say, an average
Print Command/Control+P | of 4 seconds, once you've factored in nested menus.
Rulers Command/Control + R If the average creative selects 100 menu items a
Select All Command/Control + A day, this comes to 6.66 minutes a day, 33.33 min-
Show Grid Command/Control +' utes a week, 2.22 hours a month and 26.24 hours a
Show Guides Command/Control +: year. Over the course of a 30-year career, it amounts
Cut Command/Control + X to 799.2 hours, or 33.3 days. If for no other reason,
Copy Command/Control +C use keyboa_rd commands so you'll be a}ble to retire a
R T e month earlier th_a_n you'd have otherwise done.
Adobe unifies common shortcut commands
Undo/Redo Command/Control + Z . .. .
across many of its applications (Figure 1). If a CS
Save Command/Control + 5 . . .
: menu item doesn’t have a shortcut displayed next to
Save As... 5h5|ﬁ +Command/Contral| ¢ v, can assign one by selecting Keyboard Short-
2 cuts from the Edit menu.
Zoom In Command/Control + +
Zoom Out Command/Control + - FIGURE 1. A FEW OF THE KEYBOARD SHORTCUTS COMMON TO PHOTO-
Fiton Screen | Command/Control +0 SHOP, |LLUSTRATOR, AND INDESIGN.
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Keyboard shortcuts are not unique to CS apps; all software -- including operating
systems -- displays the keyboard equivalent next to menu items.

The best way to kick the mousing habit is one shortcut at a time. Start with the
shortcuts for print and save, and aim to add at least one to your repertoire each week.
For a species able to recall pi to more than 20,000 places, 50 or so shortcuts shouldn't be
beyond any of us.

Customizing Workspaces
Just as a car mechanic doesn't always use a wrench for every job, the type of project
you're working on dictates which of the CS tools you need. In Photoshop, image retouch-
ing calls for different features than does comping;

| window [ the same thing holds true for such diverse InDesign
S e projects as a 160-page image-heavy brochure and a
Actions pe | DElete Workspace... restaurant menu.
Animation Default Workspace This is why Adobe introduced the Save Work-
grushes 1 Reset Palette Locations space feature (Window> Workspace) across the Cre-
Character Repet Kaybpard Shoceuts ative Suite apps. Note that the ability to save work-
Yasaor rof eserhens spaces appeared in Photoshop and InDesign in the
Histogram Keyboard Shortcuts & Menus... . .
History first CS, but lllustrator and Dreamweaver had to wait
Info F8 Automation for CSZ
Layer Comps Basic . -
Layers F7 | Color and Tonal Correction Save Workspace lets you create customized
v Navigator Image Analysis . . R
 aptions Sdintin s b Relptching workspaces for different kinds of projects. When you
Paragraph Printing and Proofing select the appropriate workspace, all the required pal-
v Paths Web Design .

Styles i Kk T ST ettes appear in the pop-out palette_ drawer (or dock-
swatches Working with Type ing panel, in the CS3 apps) on the right of the screen.
e Photo retouching Once you spend a bit of time tailoring workspaces
Compositions H Y
Cerowding oE o to your most common project types, it's a breeze to

switch between them (Figure 2).

Save Workspace

Name: |Texturing

|( Save )

Cancel )

— Capture
@ Palette Locations

Ficure 2. IN PHOTOSHOP, WHEN YOU SAVE A UNIQUE WORKSPACE, IT'S
POSSIBLE TO CAPTURE INFORMATION RELATING TO PALETTE LOCATIONS,
KEYBOARD SHORTCUTS, AND MENUS, MEANING THAT YOU DON'T WASTE

E Keyboard Shortcuts
E Menus

TIME SHUNTING, SHUFFLING, AND SEARCHING WHEN MOVING FROM ONE
TYPE OF PROJECT TO THE NEXT.

Scripts

Many creative processes have repetitive elements, which is why the CS apps can
import scripts that free you from those boring tasks. Your first script resource can be the
apps themselves: In Photoshop and lllustrator, go to File> Scripts; in InDesign, Window>
Scripting> Scripts. But don't stop there. If you build a library of scripts that covers as
many process-crunching eventualities as possible, you'll be better-equipped to concen-
trate on what you love to do.

Mercifully, you needn't be a codehead to compile a stack of scripts, because at
Adobe Exchange there are hundreds of useful scripts available for free download. Adobe
Exchange is Adobe's upload area for CS users to share resources, such as scripts and ac-
tions (more of which later).

One guide to a script's usefulness is its number of downloads. For example, an InDe-
sign script for automatically generating calendars has been downloaded more than 15,000
times, while another for multiple PDF imports has nearly 10,000 hits.
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Xalal
Photoshop Scripts

Dr. Br's Image Processor
En'.:. il Brown Oclob: 2003
5,026 Downloads

Dr. Brown's Image Processor is a java scrip! utility that

can only be used with Adobe Photoshop CS. Itis

_Aduhe = Photoshop Scripts

designed for phatographers and designers who need

o process large numbers of images, quickly and

efficianty. It is designed o balch process these imapges

without having o create an Action.

Platform:
File format:
Licensa:
Language:
Cost:

Download

Win | Mae
ZIP | T5 KB
Freeware
English
Free

= view sample

*+ | Add to favorites

*/ Add o alerns

-1
S ]

In the Photoshop area, Russell Brown,

~ senior creative director at Adobe, provides

the star script. His hugely popular Image
Processor allows you to process large num-
bers of images quickly and efficiently (Figure
3). Another useful script adds a watermark
to images.

Ficure 3. ADOBE EXCHANGE IS A GREAT RESOURCE FOR
DOWNLOADING TIMESAVING SCRIPTS AND ACTIONS FOR CS
PRODUCTS. THIS PHOTOSHOP SCRIPT LETS YOU PROCESS IM-
AGES QUICKLY AND EFFICIENTLY.

And for lllustrator, the most popular
script rounds any selected corner of path
items.

Actions

Anyone with CS, CS2, or CS3 versions of Photoshop and Illustrator who isn't using
these apps’ Actions feature should seriously consider doing so.

An Action is a series of commands you play back on a single file or a batch of files
-- menu commands, palette options, tool actions, and so on. Photoshop and lllustrator
come with predefined actions (Windows> Actions) for common tasks (Figure 4). You can
use them as is, customize them to meet your needs, or create new Actions. In Photoshop,
for example, you could create an Action that applies an Image Size command to change
an image to a specific size in pixels, followed by an Unsharp Mask filter that resharpens
the detail, ending with a Save command that saves the file in the desired format.

FIGURE 4. ILLUSTRATOR (LEFT) AND PHOTOSHOP
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¥ __| Default Actions
b Opacity &0 {selection)

= Opacity 40 Screen (selection)

B Apply Default Sayle iselection)

B Save For Web GIF 64 Dithered

A aRa
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W Save For Web PG Medmum

Y Save for Web
Format: IPEG
Interfaced: Mo
Cualiry: 30
Optimized: Yes
humbaer of Passes: 1
Blur: &
Mate: Yes
Watre Color Red: 255
Matte Color Green: 255
Martte Color Blue: 255
Anti-aliasing: Yas
Clip to Arthoard: No
Save HTML File: No

In: Macingash HD.

B Save For Web PNG 24
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B Simplify (selection)

= Samplify Straight (selection)

B Revern

b= Delete Unused Panel items

Ruazgza
T
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v Vignette (selection)

2 (RIGHT) SHIP WITH HANDY ACTIONS THAT CAN AUTO-
MATE OFT-PERFORMED TASKS.

.

w Make snapshat

From: Cusrent History State

Using: full document
w Feather
Radius: § pixels
Layer Via Copy
¥ Show current Liyer
With Teqgle Others
“Make fayer

Actions are stored in sets to help
you organize them. You can record, edit,
customize, and batch-process Actions,
and you can manage groups of Actions
by working with Action sets.

You can record most commands

v Fill
using: whits
Opacity: 100%
Mode: normal

W Mowve current Layer
To! previcus lager

B Frame Channel = 58 piocel

B Wood Frame - 50 pixel

and tool operations in Actions, and you
can include stops while you perform tasks
that can't be recorded (for example, using
a painting tool). Actions can also include
modal controls that let you enter values in
a dialog box while playing an Action.

B CastShadow (typel
| 3 \‘Ip:l-s-pr— H.rﬂl r‘r‘lnn-; l'\'pﬂl-

B Custom RCE ro Grayscale

Adobe Exchange includes actions
for Photoshop, with a staggering 5,000

= Molien Lead

= Make Clip Pagh (selection)
B 3epla Toning ilayer)
= Quadrant Colosrs

ready for download. Use the advance
search option to narrow down the ac-
tions in which you're interested, choos-

B Save As Phatoshap PDF

| 2 G_ra dient Map

ing search phrases such as "workflow",
"conversion”, "frame", etc.
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Version Cue

Do files with naming conventions such as "final_final_final" litter your hard drives?
Do you often seek clarification about the ultimate version of any given file (only to discover
the person you need is in a meeting?) Worse, do you ever discover you've been working
on the wrong document?

Those who answered in the affirmative to one or all of these questions need to re-
visit their workflow, because it will almost certainly be slowing you (and your colleagues)
down.

Again, Adobe provides a ready-made CS workflow solution, called Version Cue (Fig-
ure 5). This server-based file-management system enables small- to medium-sized cre-
ative teams to work more efficiently by tracking the evolution of a digital asset -- an im-
age, drawing, layout, and so forth -- as a series of versions.

olders

szt S Create Meta

i Deskto
c : . Ficure 5. WitH VERsioN CUE, YOU CAN CENTRALLY

Omputer

= P TemplatE Name: MANAGE SHARED PROJECT FILES AND TRACK FILE STATUS
@ Network WITH COMMENTS -- MUCH MORE EFFICIENT AND SAFER
B osx THAN HOMESPUN FILE-SHARING SYSTEMS. ALSO, WITH

Choose the metadata Version Cue CS3, JAVA DEVELOPERS CAN CUSTOMIZE

3 e THE FILE-MANAGEMENT CAPABILITIES TO SUPPORT SPECIF-
rowse Servers PT
v D IPTC Core IC WORKFLOWS FOR SMALL CREATIVE TEAMS.

=» Recent Projects | Creator
Ml VC_WebTeam [#] Creator: Job Title With Version Cue, you can centrally
[ Icieator: fddress manage _shared project files and t_rack file
= ; status with comments. Because it's inte-
grated with the CS components, Version

Cue allows all of this to happen without anyone leaving the design environment. And it
does these things without relying on dodgy file-naming conventions or other homespun
workflows.

Version Cue is included with the following CS3 bundles: Design Premium; Design
Standard; Web Premium; Web Standard; and Master Collection. For video tutorials on us-
ing Version Cue, go to www.adobe.com/designcenter/video_workshop/.

B Version Cue
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