
XXXX - ANIMATED BANNER                             1 N/08/08

PR
O
JE

CT
 

N
o.

XX
XX

INTRODUCTION TO
GRAPHICS

ANIMATED 
BANNER

“How do you create banner ads and other animated 
Web graphics in Photoshop?” This question is posed fre-
quently, often with the response, “You used to be able to in 
ImageReady, but Adobe got rid of it; you can’t make ani-
mated graphics in Photoshop CS3.”

It’s true that ImageReady is gone, but Photoshop CS3 
took over ImageReady’s role as Web graphics animator.

This information sheet will show you how to create 
an animated banner ad that uses two types of animations: 
motion, in which one or more objects move, and transfor-
mation, during which one or more objects change shape, 
size, color or are replaced with other objects.

   1. Choose File > New to create a new document.

   2. Choose “Web” from the Preset menu and “Me-
dium Rectangle, 300 x 250” from the Size menu (Figure 
1). Photoshop will fi ll in the rest of the settings, including a 
white background color. Even if you don’t want a white back-
ground, let Photoshop create the Background Layer now to 
save you the step of turning a fi lled standard layer into a 
Background Layer later.

Figure 1. The New Docu-
ment dialog creating a Me-
dium Rectangle ad.
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   3. Name your PSD in the New Document dialog. I’ll 
name mine “Ad Medium Rectangle”. Click OK to create the 
new document.

   4. Open the Layers panel from the Window menu. 
You’ll see a locked Background layer, which, if you kept the 
default, is white. If you’d like a different background color, 
use the Color panel to mix up the new color and the Paint 
Bucket tool to pour that color over the white area. I’m go-
ing to skip that because my ad will use a background image 
I’ll import shortly.

   5. Save your ad as a PSD.

   6. Now you’ll create an object that stays the same 
shape, size, and color, but moves from one side of the ad 
to the other.

      Go to File > Place and navigate to the location of 
the object you’d like to insert. My object is the client’s logo, 
Logo.ai. Because my image is an Illustrator fi le, Photoshop 
prompts me to choose a means of cropping it in the Place 
PDF dialog. I’ll choose to crop to the “Art Box” -- the area 
of the actual artwork. If you place a JPEG, TIFF, PNG, or 
other raster image format, Photoshop will skip the Place 
PDF dialog. Either way, Pho-
toshop inserts the graphic in 
the center of the artboard, 
scaled to fi t within it (Figure 
2).

Figure 2. A placed graphic 
ready for positioning and re-
sizing.
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   7. Scale the object as needed using the control 
corners and holding Shift to maintain proportions while re-
sizing.

   8. Position the motion object in its starting place. In 
the case of my ad, the Acme Corporation logo will actually 
begin outside the image area, below the bottom edge (Fig-
ure 3). Note that I also placed a background image, rather 
than using a solid color Background Layer.

Figure 3. The client logo will 
begin its motion animation 
from off screen.



XXXX - ANIMATED BANNER                           4 N/08/08

   9. Now begins the actual animation. From the Win-
dow menu, open the Animation palette. It will initially dis-
play a single layer (Figure 4).

Figure 4. The Animation 
palette.

      Photoshop CS3 Extended has two modes -- frame 
animation mode and timeline animation mode. For this 
project, stick with frame animation mode. If your Anima-
tion palette isn’t already in frame animation mode, choose 
the Convert to Frame command from the fl yout menu in the 
top-right corner of the Animation palette.

  10. At the bottom of the palette, click on the Du-
plicates Selected Frames button (which looks like a New 
Frame button) to add a second frame in the Animation pal-
ette.

  11. In the Layers panel, select the object to be 
moved, then drag the object to the place where its anima-
tion should end (Figure 5). In my case, the logo moves in a 
single, straight line; even if you want a more complex path, 
like an S-curve, leave it as one straight line for now. Later, 
you can repeat these steps to create several straight-line 
motion paths that make the complete route.

      Figure 5. Frames 
1 and 2 showing the object 
at its motion start and end 
points, respectively. If you 
click on Frame 1, the moved 
object will snap back to its 
start position; click on Frame 
2 to see it immediately move 
to the end position.

  12. To smooth the motion, you’ll use tweening, which 
automatically creates frames in between the beginning and 
end points. Click on Frame 1 to select it, then click the but-
ton the Tweens Animation Frames button to the left of the 
Duplicates Selected Frames button. The Tween dialog ap-
pears (Figure 6).
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Figure 6. The Tween dialog.

      To move the “Acme 
Corporation” logo up into my 
ad smoothly, I’ll tween With 
“Next Frame” (Frame 2), 
add 10 frames, use All Lay-
ers, and to consider only the 
“Position” parameter. When 
I click OK, my animation in-
crease from two frames to 
twelve (Figure 7). Click the 
play button at the bottom of 
the Animation palette to see 
your tweened animation.

Figure 7. Tweened, my motion animation is now 12 frames. Click on the fi gure to see it 
full-sized.

      You may notice that your 
animation stutters, each frame 
causing the object to seemingly 
step, pause, and step again (Figure 
8). The solution is probably not to 
add more tween frames, but to ad-
just the frame delay rate.

Figure 8. The animated banner ad 
thus far.
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  13. At the bottom of each frame, you’ll see a num-
ber followed by the word “sec,” which indicates the seconds 
each frame displays. Because I’m moving the logo to catch 
the viewer’s attention before showing any ad copy, I want 
the animation to be fast.

      Click on the fi rst frame in the animation on the 
Animation palette. Then, while holding the Shift key, click 
on the last frame to select all the intervening frames. Now 
at the bottom of any frame, click on the tiny black arrow di-
rectly above the current frame delay rate. Up pops a list of 
common frame delay rates (Figure 9). Choose one or select 
Other and input your own delay rate in seconds, tenth of 
seconds, or hundredth of seconds. Your choice applies to all 
selected frames instantly.

Figure 9. Adjusting the 
frame delay rate with the 
pop-up menu. Click on the 
fi gure to see it full-sized.

      After setting the frame delay rate on my fi rst 11 
frames to “0 sec.” and the delay on the last frame to “10 
sec.,” the logo moves smoothly across my ad and pauses 
before repeating (Figure 10). That’s all the motion anima-
tion I’m going to use in this ad. Now it’s time to focus on 
the ad copy using transformation animation.

Figure 10. With appropriate frame 
delay rates, my animated banner ad 
is looking better.
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14. Because this is a banner 
ad with a signifi cant amount of 
advertising copy, I’ll use an object 
replacement technique to show a 
single line of copy, pause, swap in 
a new line of copy, and repeat un-
til everything has displayed.

Go to the last frame on the 
Animations panel and create and 
select a new frame after it. This 
ensures that you don’t acciden-
tally change the fi rst part of the 
animation.

15. On the Layers panel, 
click the New Layer Group button, 
which looks like a folder. Name the 
new group something that makes 
sense for your ad; in my case, 
that’s “Copy.”

16. Inside the “Copy” group, 
create each of the individual layers 
of replaceable elements. If, like my 
ad, yours will use the replacement 
technique to display multiple lines 
of copy, create a new text layer 
for each frame of text to be dis-
played. You should wind up with a 
Layers panel that looks something 
like mine (Figure 11).

Figure 11. My Layers panel after 
creating the replaceable text lay-
ers.
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17. Choose your fi rst line of 
copy or fi rst layer to display, and 
then toggle the eyeball layer visi-
bility icon beside each of the other 
replaceable layers to hide them. 
Your document should now include 
all the static elements -- for in-
stance, the logo, background, and 
so on -- and one of your replace-
able layers.

18. Return to the Animation 
palette. Set the frame delay rate 
on the current frame to be long 
enough that the average viewer 
can read or absorb the frame con-
tent. (I chose “2 sec.”) You can al-
ways change the frame delay rate 
later.

19. Create a new frame, 
freezing the last one with the fi rst 
replaceable layer active.

20. On the new frame, hide 
the fi rst replaceable layer and 
show the second (Figure 12).

Figure 12. Creating my next re-
placement frame, I’ve hidden the 
layer containing the fi rst line of 
copy and shown the second.
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  21. Repeat the last two steps until you’ve created 
frames to display each of your replaceable layers. You can 
also create tweens for the object replacement frames so 
that, for example, one line of text fades into the next. With 
my ad I’m going to leave them without tweens, keeping a 
sharp, clean replacement between them.

  22. Now consider how many times the ad should 
loop. You can change the number of times an animation 
repeats with the dropdown menu at the bottom-left of the 
Animation palette (Figure 13). Click the arrow beside the 
menu to expose a list that includes options “Once” (the 
animation plays once and then stops), “Forever” (the ani-
mation loops continuously as long as it’s on somebody’s 
screen), and “Other,” wherein you defi ne a specifi c number 
of repetitions before it stops and stays on the last frame.

Figure 13. The Animation palette’s repetition menu. Click on the fi gure to see it full-
sized.

23. Now, preview the ad by returning to the fi rst 
frame in the animation and clicking the Play button. How 
is the timing? Does everything move smoothly and quickly 
enough to be read and absorbed by the viewer? Is there 
any stuttering? Nothing sits on screen for too long, does it? 
Is there suffi cient pause at the end of the animation before 
it repeats?

  24. Once you’re satisfi ed with your ad in Photoshop, 
it’s time to do a little cleanup and export it to the fi nal GIF 
for live testing.

From the Animation palette’s fl yout menu, choose Op-
timize Animation to open the corresponding dialog (Figure 
14). For most fi les, you’ll want to check both Bounding Box 
and Redundant Pixel Removal. In both cases, the result is a 
smaller fi le that downloads faster and plays more smoothly 
in a Web browser.
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Figure 14. The Optimize 
Animation dialog. Click on 
the fi gure to see it full-
sized.

  25. Choose Save For Web and Devices from the File 
menu to open the Save For Web and Devices dialog (Figure 
15).

Figure 15. The Save For 
Web & Devices dialog. 

  26. If you’re not there already, switch to the Opti-
mized tab in the top-left corner. The Optimized view shows 
your ad as it will appear online, and it updates to refl ect 
changes made on the right side of the dialog.

27. Begin with a Preset beneath the Save, Cancel, and 
Done buttons in the top-right corner. For an animated ban-
ner, begin with the “GIF 128 Dithered” preset. That will set 
the fi le format to GIF, the number of colors to 128 (out of a 
possible 256), and the dithering option to “Diffusion.” It will 
also set other options, some of which we’ll need to change.
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28. Try reducing the number of colors in your anima-
tion. Often you can produce a beautiful graphic with only 
64 or even 32 colors and not notice the difference -- ex-
cept that the fi le size will drop dramatically. Speaking of 
which, you can preview the expected output fi le size in the 
bottom-left corner of the Save For Web & Devices dialog 
(Figure 16). The fi le size and expected download time at 
the specifi ed speed will update in real time to refl ect any 
changes made to the optimize and export options.

Figure 16. The Save For Web & Devices dialog 
presents a preview of the fi le size and approximate 
download speed of your graphic as you set the opti-
mization and export options.

29. Make sure that the Transparency option is checked, 
or you won’t derive any benefi t from the Redundant Pixel 
Removal optimization you did in step 24. I also recommend 
changing the Color Reduction Algorithm dropdown from 
the default “Selective” to “Perceptual.” Either will seek to 
maintain a consistent color palette across all frames of the 
animation, but “Perceptual” tries to make the output col-
ors look more like the input colors. Leave the rest of the 
options at their defaults. Figure 17 shows the settings I’m 
going to use to export my Medium Rectangle ad for Acme 
Corporation.
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Figure 17. The optimize and 
export settings.
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  30. Click Save and choose a location and fi lename 
for your animated banner ad.

  31. Once the GIF is saved to your hard drive, save 
the original document in Photoshop to embed the optimize 
and export settings within the fi le.

  32. Upload your ad to a Web server and view it 
in your browser. Download and animation speeds can vary 
signifi cantly between fi les viewed in Photoshop on your lo-
cal computer, and on a Web server and viewed through an 
actual Internet connection. Return to Photoshop to make 
any adjustments in frame delay rates or optimization and 
export settings.

      In Figure 18 you can see the fi nished ad, tweaked 
and tucked, optimized and ready for insertion.

Figure 18. he fi nal animated 
Medium Rectangle ad.

Congratulations! You’ve just made an animated banner ad in Photoshop CS3!


